Upstream Carrier issues

Incident Report for Iris Technology Group

Resolved

This incident has been resolved.
Posted Feb 21, 2026 - 13:17 EST

Identified

we are investigating an issue with one of our voip carriers. updates to be provided as soon as the vendor updates
Posted Feb 20, 2026 - 13:34 EST
This incident affected: Sip Trunks.